18:04:21 <itchka__> #startmeeting
18:04:21 <chwido> Woof! Let's start the meeting. It's Thu Jan 21 18:04:21 2016 UTC. The chair is itchka__. Information about me at https://wiki.openmandriva.org/en/Chwido.
18:04:21 <chwido> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:04:21 <chwido> You should add extra chair(s) just in case, with #chair nick.
18:04:21 <chwido> Have a good meeting, don't bark too much!
18:04:28 <itchka__> #item 1
18:04:46 <itchka__> #topic Release procedure: project status and next steps
18:05:23 <klebedeff> rugyada: word to you:)
18:05:36 <rugyada> I sent email few min ago
18:05:44 <klebedeff> yep see it
18:06:02 <rugyada> hope there is where we left :)
18:06:33 <itchka__> I don't see it yet
18:07:54 <rugyada> so what we need now is to go through the steps and fine-tuning them for our needing
18:08:20 <rugyada> itchka__: in council ML
18:08:29 <rugyada> Release schedule - Release procedure
18:08:37 <rugyada> it's the topic.
18:08:48 <klebedeff> rugyada: the picture is clear, I am not sure what exactly you wish to do now:)
18:08:51 <klebedeff> please comment
18:09:13 <itchka__> I'll try my webmail connection
18:10:24 <rugyada> well we stopped there. we didn't finalize or approve or whatever, simply we left it in standby :)
18:11:03 <klebedeff> in the ideal world, how it should function?
18:11:38 <klebedeff> It is made public, accepted, and then everybody just looks there when we have release? or we integrate it into Project with automatic reminders?
18:11:48 <klebedeff> how exactly we want it?
18:12:19 <itchka__> I don't seem to have the mail Cristina
18:12:25 <rugyada> the picture is for ease to visualize the steps
18:13:36 <rugyada> I'd say please everyone have a (further) look and approve or comment
18:13:42 <rugyada> wdyt?
18:14:14 <rugyada> this can be not right now also.
18:14:25 <klebedeff> itchka__: I see it...
18:14:35 <rugyada> we have some time :)
18:15:13 <klebedeff> to have it quickest we can do during the meeting, but to cover all - probably worth to make a loomio
18:15:37 <itchka__> Cristina if I could see it I would probably approve. We need a procedure but when I tried to institute one I ran into all sorts of resistance. Perhaps things will be easier nown
18:16:18 <rugyada> I'd say also when obvious things are ok to involve in the discussion also the guys like Wayne, John
18:16:30 <klebedeff> itchka__: please check email again, i forwarded to you
18:16:49 <rugyada> I may miss some names here but you know.
18:16:59 <itchka__> Ok
18:17:26 <klebedeff> we have discussed the procedure quite in detail before you summed it up rugyada . Imo we are ok to accept it now and to push for further steps
18:18:05 <rugyada> ok
18:18:48 <rugyada> additional comments can be written in gdoc I sent the link too.
18:19:02 <itchka__> I've got it now so I'm looking
18:19:17 <klebedeff> if there will be any objections from those who do take part in the release - then we can always adapt
18:19:24 <HisShadow_> greetings
18:19:28 <klebedeff> hi HisShadow_
18:19:50 <rugyada> klebedeff: exactly. that's what I meant :)
18:20:09 <itchka__> There's one thing missing as far as I can see.
18:20:26 <klebedeff> ok, so we will vote in a minute - if we accept it, next step is make it official and upload to wiki? or where?
18:21:04 <rugyada> discussion was held in July, so maybe something got forgotten.
18:21:36 <rugyada> klebedeff: wiki I think
18:21:46 <rugyada> it's easy to edit.
18:21:56 <itchka__> I think that may be a bit summary Kate. I think the Cooker guys should see it first it should also be mailed to theQA and Infra teams
18:22:12 <klebedeff> itchka__: - and then?
18:23:25 <itchka__> and then we accept any comments or constructive criticism made address it and then publish it.
18:24:15 <rugyada> itchka__: so will you email infra, cooker, qa and everything involved please?
18:24:18 <klebedeff> do we plan to integrate it into project? - with reminders etc
18:25:22 <itchka__> The thing that is missing is verification of links to ensure that 1. They point to correct and 2. That the files can actually be downloaded. This should aply to all new links published.
18:25:30 <rugyada> everything = every team or people :)
18:26:05 <klebedeff> itchka__: yeeeeees
18:27:42 <rugyada> I've edited the pad
18:27:43 <ashledombos_> hi
18:28:04 <klebedeff> hi ashledombos_
18:28:11 <rugyada> hi ashledombos_
18:29:11 <itchka__> It is already in project Kate it has be there for some time. To be able to use project for the whole job though will require some more work. Project did not have the necessary functionality to do it properly at the outset but now it does and I did start on getting it sorted but there's so many other things to get done such that I won't have any time until after FOSDEM.
18:29:13 <ashledombos_> sorry being late
18:29:23 <itchka__> Hi ashledombos_
18:30:10 <itchka__> BTW links verification should happen before any announcements.
18:30:57 <rugyada> done
18:32:10 <klebedeff> itchka__: exactly, it needs to be tuned and adressed correctly in project etc... just thinking what is the best way to apply the procedure
18:33:38 <itchka__> That's where project comes in...completed tasks can be signed off this can trigger emails to inform whoever needs to know about the next stage.
18:33:58 <itchka__> For now though I have an idea
18:34:11 <itchka__> We need a gatekeeper
18:34:28 <rugyada> I suggest to write names near each task so everyone knows who to address for what
18:34:46 <klebedeff> gatekeeper?
18:35:24 <rugyada> I need to always have a dictionary when itchka__ is chatting :)
18:35:26 <itchka__> That is one individual who ensures that all the steps required have been taken before the "Release Announcment Button2 is pressed.
18:36:34 <klebedeff> rugyada: ;))))
18:36:50 <rugyada> yes :/
18:36:59 <klebedeff> *me too often:)
18:37:34 <itchka__> When each task is finished this individual is mailed with a marker for that task and he ticks all the tasks off a list. When they are all completed he/she will post the link for the release announcement.
18:37:40 <klebedeff> itchka__: that is easy. to each task we can add "... AND inform secreatry"
18:38:43 <rugyada> -1 for one-man/woman task
18:38:52 <klebedeff> why rugyada
18:39:25 <itchka__> BTW The term "release announcement" encompasses all info speaking of the release. So all the social media sites etc also come under this "button"
18:39:26 <rugyada> cause just 1 man is not enough
18:39:48 <rugyada> man/woman.. no difference (in this case :)))) )
18:41:08 <itchka__> I could seriously misinterpret that Cristina :)
18:41:20 <rugyada> ideally there should not be any task handled by just one person
18:41:35 <rugyada> itchka__: ?
18:41:50 <itchka__> One man is not enough?
18:41:55 <rugyada> ah
18:41:57 <rugyada> lol
18:42:26 <klebedeff> rugyada: Colin means only checking in the boxes - that things are done. So that is fine for one person
18:42:26 <rugyada> (rotfl) /me naive....
18:42:35 <klebedeff> or you mean somehow else?
18:43:22 <itchka__> Yes that what I mean Kate.
18:43:24 <rugyada> ok. but imagine if the person is not available for whatever reason
18:43:53 <rugyada> hope it's more clear what I mean now :)
18:44:14 <klebedeff> it should be said then that bureau should be informed (3 people)
18:44:37 <klebedeff> and they lead the procedure together
18:44:46 <rugyada> yes, something like that.
18:44:51 <itchka__> It can be a qa, infra or council member there only responsibility is to make sure that they have an email confirming that each task on the list has ben cpompleted.
18:45:30 <klebedeff> we should add it to the procedure itself: that whoever is responsible for the task, _must_ inform bureau when task is done
18:45:46 <rugyada> 2 or 3 person who know what to do. the second can take the task if the 1st is not available.
18:45:57 <rugyada> aso.
18:46:10 <itchka__> If there is more than one person the check list will have to be accessible to all 3 people.
18:48:17 <rugyada> I'm saying to pick 3 person willing to help when the time will come. 1 is the "designen" and the other are the delegates.
18:48:28 <rugyada> designed*
18:49:01 <rugyada> is designed right english ? dunno :)
18:49:06 <itchka__> This is detail though. I have less than 45 minutes left and I would like to be here when the FOSDEM item is discussed we can sort out the detail at a later date.
18:49:34 <rugyada> ok.
18:50:08 <klebedeff> #action itchka__ emails the accepted release procedure to all MLs to get comments and possible amendments
18:50:19 <itchka__> We can start an email thread in council ml to work out the detail.
18:50:51 <klebedeff> #action together with release procedure finalisation and amendments 3 people should be appointed for "gatekeeping" the procedure
18:51:49 <itchka__> Happy to move on?
18:51:52 <klebedeff> itchka__: please add me as chair
18:51:57 <klebedeff> before you go
18:52:07 <klebedeff> sure let's move on
18:52:10 <itchka__> #chair klebedeff
18:52:10 <chwido> Current chairs: itchka__ klebedeff
18:52:32 <itchka__> #item 2
18:52:52 <itchka__> #topic FOSDEM preparations: what we show
18:52:53 <rugyada> I'll have to go too around in 1 hour
18:53:39 <klebedeff> itchka__: your word I guess
18:53:59 <klebedeff> Bero: 2. -- should show off OMLX3 so people see we're making "real" progress instead of essentially staying on the same codebase forever, but having a 2014.2+updates box around as well can't hurt - Should try to have both x86 and ARM based devices ready to demo... How is the aarch64 laptop coming along? - I'll bring my laptop running Cooker, do we need more devices?
18:55:26 <ashledombos> klebedeff: you'll bring your laptop with cooker? :)
18:55:38 <itchka__> Ok I'm around 90% certain I can deliver a working laptop to FOSDEM. I have worked out all the interfaces and am at the stage where I am doing the mechanical interface. It's slow going but I think I will be able to finish it in time.
18:55:53 <klebedeff> ashledombos: agggrrr!!!!!
18:56:10 <klebedeff> that was quoting Bero:)
18:56:12 <itchka__> So we should have an aarch64 laptop
18:56:23 <ashledombos> yes i guessed so :p
18:56:31 <klebedeff> itchka__: that sounds great!
18:56:49 <klebedeff> keeping all fingers crossed for you:)
18:57:36 <itchka__> I need some software to run on it so I'm relying on bero and fedya to come up with the goods.
18:58:04 <klebedeff> they know that they should, right?
18:58:12 <klebedeff> *sorry for asking this:)
18:59:03 <itchka__> Well I have said it to them but it wouldn't hurt to say it again!!!
18:59:29 <klebedeff> #action klebedeff emails this log to bero and fedya:)
19:00:00 <klebedeff> so speaking of "what we need" - do we need other hardware?
19:00:29 <klebedeff> bury in mind, this is last council meeting before FOSDEM
19:00:35 <klebedeff> bear not bury lol
19:01:30 <itchka__> If we want to show off OMLX3 fully we should at least have a decent sized monitor. We don't want to have to rely on the little 14 inch laptop..
19:01:48 <klebedeff> i bring monitor
19:01:56 <klebedeff> and cords for it, and extenders
19:02:07 <klebedeff> I mean laptops or something else?
19:02:54 <klebedeff> *as for banners, I received them, they are great! somehow though gaming banner is a bit oversized, but we will find a way:)
19:03:08 <klebedeff> applause to Cristina:)
19:03:11 <klebedeff> rugyada:
19:03:22 <itchka__> Hurrah!!!
19:03:41 <klebedeff> hiphip-hurrrah!
19:04:07 <itchka__> Kate we can stretch it around 3 corners.
19:04:21 <klebedeff> we will find a way for sure
19:04:37 <klebedeff> itchka__: I leave it with you to think of what other things we may need there
19:04:45 <klebedeff> i assume we are ok, but...
19:06:11 <itchka__> Well we did chop through their tablecloths last year I'm not sure whether that was the best thing to do.
19:06:54 <klebedeff> we will again:))))
19:07:18 <rugyada> klebedeff: good
19:07:26 <klebedeff> I will get tomorrow those fixes - to fix the holders for banners, and then I am well prepared I guess
19:07:56 <klebedeff> will have a look if I get the third holder as well, but we will be fine with 2 imho
19:07:59 <itchka__> I think I have a tablecloth I can bring for the job I'll see. I have the tie straps but we could do with better poles.
19:08:15 <klebedeff> will not hurt itchka__
19:08:26 <klebedeff> ok so with that we are through I guess
19:08:34 <klebedeff> moving on?
19:08:44 <itchka__> What we need are the bamboo canes that people use in their gardens.
19:08:57 <klebedeff> oops
19:09:05 <klebedeff> the metal things you did not like?
19:09:10 <klebedeff> they do the job
19:09:15 <itchka__> You and I will do a Skype on this yes?
19:09:37 <klebedeff> sure
19:09:45 <itchka__> Thet wern't very stiff so the banner sagged.
19:09:57 <klebedeff> let's do item 4
19:10:01 <itchka__> Look at the pics
19:10:04 <klebedeff> while you are here
19:10:18 <itchka__> Ok
19:10:25 <klebedeff> #topic ABF switchover (we need to discuss how we publicise, do we attempt to use it to promote the distro. There's also the issue of whom we offer logins to etc)
19:10:27 <itchka__> #item 4
19:10:34 <klebedeff> done:)
19:11:20 <klebedeff> itchka__ the floor is yours I guess?
19:11:42 <itchka__> Right now what I'm about to say may be a little confusing for the non-technical but all will become clear.
19:13:12 <itchka__> The new abf is almost complete in around two weeks, maybe three it will beready to roll. This new abf is different from the old one in taht it is not so centralised.
19:14:59 <itchka__> It has been designed in such a way as to make it possible for any user to become a build helper it is I am told quite straightforward compared to what one had to do if one wanted to be connected to the original ABF.
19:15:33 <itchka__> There are lots of implications in this but I will only talk of one atr this time.
19:15:35 <klebedeff> sounds good so far
19:18:15 <itchka__> Because it is possible for users to connect easily to the abf network it means that we can invite our users to contribute their computers to the network when we need to do big jobs like mass build. These can often take days to complete so obviously the more machines you can throw at the netywork to compile the software the faster the job will complete.
19:19:13 <itchka__> This brings with it the idea of having "Build Events" where we gather together users for a particular mass build event.
19:22:40 <itchka__> In doing this we have to speak and interact with our community of users to organise this. This encourages communication. Secondly if we can get users to participate it gives them a sense of contributing or investing in the distro giving them a sense of participation. Finally there is the ability to set records. Which can be used to inject some fun into the proceddings.
19:22:46 <itchka__> proceedings
19:23:26 <itchka__> i.e. we try andset a record for the number of builders connected to abf at any one event.
19:23:48 <klebedeff> well, I'd say cautiously that we could try... I am not too optimistic though
19:24:08 <klebedeff> do you think this is what we should publicize from the very start?
19:26:09 <itchka__> I think we should tell our users what is on offer at least and what we would like to do/achieve
19:26:49 <itchka__> We can prepare the ground before abf is ready for final release.
19:28:32 <itchka__> I feel we should make the effort to run one such event to see what the response is. If it's poor then we will drop the idea.
19:29:32 <itchka__> Anyways I'll leave that on the table for thoughts and/or discussion. I have to go now I'm afraid.
19:38:44 <avokhmin> > This brings with it the idea of having "Build Events" where we gather together users for a particular mass build event.
19:38:49 <avokhmin> hm
19:39:00 <avokhmin> what about "trust"?
19:39:35 <avokhmin> I mean: all main nodes should be checked and from trusted servers
19:39:44 <avokhmin> to prevent something...
19:54:22 <rugyada> by my ignorance on the matter I'd say it's a good point avokhmin
19:56:33 <HisShadow_> what's the original ABF?
19:57:08 <fedya> what's up
19:58:05 <avokhmin> > topic ABF switchover (we need to discuss how we publicise, do we attempt to use it to promote the distro. There's also the issue of whom we offer logins to etc)
19:58:35 <HisShadow_> what is meant by "whom we offer logins"? anyone can register
19:59:19 <fedya> i want to suggest abf for guys from archlinuxarm
19:59:50 <avokhmin> fedya: abf.io || abf.oma ?
20:03:11 <klebedeff> well, the main Q of current topic (as I get it) is "how we make a large story out of big thing - switch to own ABF"
20:03:31 <klebedeff> that is indeed a big thing, and we should push it
20:03:47 <klebedeff> Question to you, experts on the topic - is what is the best way?
20:04:03 <klebedeff> which features will be most popular, have most potential?
20:07:44 <avokhmin> I think that we should create all projects
20:07:51 <avokhmin> and try to perform mass build
20:07:58 <avokhmin> and if all will works
20:08:07 <avokhmin> do a public migration
20:09:06 <klebedeff> so to promote only then?
20:13:18 <avokhmin> in this case we will 99% that all works
20:13:46 <avokhmin> in this case we will 99% know that all works*
20:15:37 <klebedeff> I can say smth only very cautiously and humbly on the topic, but that sounds very reasonable, to promote only when we are sure that everything works well
20:16:35 <avokhmin> fedya: HisShadow_ what do you think?
20:19:01 <rugyada> I have to go
20:19:15 <rugyada> bye everybody
20:19:35 <rugyada> ciaooooooo :)
20:20:00 <avokhmin> Bye rugyada!
20:21:19 <HisShadow_> avokhmin: we could do a massbuild I guess, we've been testing it with ~100 projects
20:21:55 <avokhmin> I can take a last PG dump from abf.io
20:22:01 <avokhmin> if need
20:22:16 <avokhmin> or need somehow to create all projects
20:22:36 <HisShadow_> avokhmin: https://abf.openmandriva.org/openmandriva you mean these?
20:22:58 <avokhmin> anyway, you should say: when we should use new ABF as main service
20:25:56 <fedya> abf.oma of course
20:26:02 <fedya> i haven't any access to abf.io
20:29:30 <avokhmin> better to suggest to archlinuxarm own instance and support for $ :D
20:30:10 <avokhmin> ok, itchka__ klebedeff something else?
20:31:02 <klebedeff> not from me:(
20:31:10 <klebedeff> itchka__ is away at the moment
20:31:59 <HisShadow_> avokhmin: assuming those guys have $ :P
20:40:02 <fedya> i want to suggest as free
20:40:08 <fedya> with their hardware
21:30:09 <klebedeff> avokhmin: how we round up the topic?
22:44:51 <rugyada> end meeting
22:46:23 <rugyada> #chair
22:46:39 <rugyada> ^^
07:04:32 <klebedeff> #endmeeting